Red Canary supports the same platforms and Operating System versions as the underlying Endpoint Detection and Response platforms that we leverage. Please refer to the vendor-specific resources below for the most up-to-date information.

Carbon Black Response

Our organizations most commonly run Carbon Black Response on the following ranges of platforms:

  • Windows XP SP3 => Windows 10 v1909
  • Windows Server 2003 => Windows Server 2019
  • MacOS 10.7.4 (Lion) => 10.15 (Catalina)
  • RHEL/CentOS 6.4 => 8.1

Don't see your OS or need to understand more about the EDR sensor's compatibility? Click here to see the comprehensive list.

Carbon Black ThreatHunter

Our organizations most commonly run Carbon Black ThreatHunter on the following ranges of platforms:

  • Windows 7 SP0 => Windows 10 v1909
  • Windows Server 2008 R2 => Windows Server 2019
  • MacOS 10.10 (Yosemite) => 10.15 (Catalina)
  • RHEL/CentOS 6.6 => 7.7

Don't see your OS or need to understand more about the EDR sensor's compatibility? Click here to see the comprehensive list.

Endgame

Our organizations most commonly run Endgame on the following ranges of platforms:

macOS:

  • Sierra (10.12), High Sierra (10.13), Mojave (10.14), Catalina (10.15)

Windows (64 and 32 bit):

  • Windows 7 SP1
  • Windows 8.1
  • Windows 10 (v1507, v1511, v1607, v1703, v1709, v1803, v1809, v1903, v1909)
  • Windows Server 2008 R2 SP1, 2012 R2, 2016, 2019

Linux:

  • RHEL 6.5, 7, 8
  • CentOS 6.5 x64, 7, 8
  • Ubuntu 16.04, 18.04 (pre Kernel 5)

Solaris:

  • Solaris 10 (5.10) x86 SPARC

Don't see your OS or need to understand more about the EDR sensor's compatibility? Visit your Endgame support portal for more details.

CrowdStrike Falcon

Our organizations most commonly run CrowdStrike Falcon on the following ranges of platforms:

  • Windows 7 SP1 => Windows 10 v1909
  • Windows Server 2008 R2 SP1 => Windows Server 2019
  • MacOS 10.13 (High Sierra) => 10.15 (Catalina)
  • RHEL/CentOS 6.7 => 8
  • Ubuntu (14.04LTS, 16.04LTS, 16-AWS, 18.04 LTS, 18-AWS)
  • Oracle Linux (6 - UEK3, 4 / 7 - UEK3, 4, 5)
  • SUSE Linux Enterprise (11.4, 12.1 - 12.4, 15)
  • Amazon Linux 2
  • Amazon Linux AMI (2017.03, 2017.09, 2018.03)

Don't see your OS or need to understand more about the EDR sensor's compatibility? Click here to see the comprehensive list.

Did this answer your question?